Ads Top

Yuki Chan - Automate Pentest Tool

screenshot

The Yuki Chan is an Automated Penetration Testing tool this tool will auditing all standard security test method for you.

Features

  • Automated
  • Intel-Gathering
  • Vulnerability Analysis
  • Security Auditing
  • OSINT
  • Tracking
  • System Enumeration
  • Fuzzing
  • CMS Auditing
  • SSL Security Auditing
  • And Off Course This Tool Designed For Targetted Pentesting Too

Modules

  • Whois domain analyzer
  • Nslookup
  • Nmap
  • TheHarvester
  • Metagoofil
  • DNSRecon
  • Sublist3r
  • Wafw00f
  • WAFNinja
  • XSS Scanner
  • WhatWeb
  • Spaghetti
  • WPscan
  • WPscanner
  • WPSeku
  • Droopescan ( CMS Vulnerability Scanner Wordpress, Joomla, Silverstripe, Drupal, And Moodle)
  • SSLScan
  • SSLyze
  • A2SV
  • Dirsearch

Install

this tool is only designed for Linux OS so if you are not using Linux OS im sorry dude but if you have Android Smarphone or Tablet you can run this tool via Termux or GNURoot Debian
so Are You Ready ??
Let's Start It
Ok in my recent OS (Kali Linux) has been already installed this module
  • Nmap
  • Wafw00f
  • WPScan
  • SSLScan
  • SSLyze
So if your OS Doesn't Have it
you can install it first here i give you resource
  • Nmap
Red Hat, Fedora, Mandrake, and Yellow Dog Linux with Yum
yum install nmap
Debian Linux and Derivatives such as Ubuntu
apt-get install nmap
more info : https://nmap.org
  • Wafw00f

cd wafw00f
python setup.py install
or simple way
pip install wafw00f
  • WPScan
Installing dependencies on Ubuntu
sudo apt-get install libcurl4-openssl-dev libxml2 libxml2-dev libxslt1-dev ruby-dev build-essential libgmp-dev zlib1g-dev
Installing dependencies on Fedora
sudo dnf install gcc ruby-devel libxml2 libxml2-devel libxslt libxslt-devel libcurl-devel patch rpm-build
Installing dependencies on Arch Linux
pacman -Syu ruby
pacman -Syu libyaml
Installing manually (not recommended)

cd wpscan
sudo gem install bundler && bundle install --without test
more info https://github.com/wpscanteam/wpscan if you cannot install WPScan don't worry just Skip it i have alternative wpscan module for you
  • SSLScan
more info about installing this module

  • SSLyze :

cd sslyze
pip install -r requirements.txt --target ./lib
or simple way
pip install --upgrade setuptools
pip install sslyze
if Nmap, Wafw00f, WPScan, SSLScan, SSLyze not installed in your OS maybe this tool not really work completely so if Nmap, Wafw00f, WPScan, SSLScan, SSLyze already installed you can next.
Q : can i skip using this tool without Nmap, Wafw00f, WPScan, SSLScan, SSLyze installed in my OS ?
A : yes you can do it but not really work completely
Ok next this is step by step for preparation for first time use
First Things First Clone This Tool

Get inside of directory
cd Yuki-Chan-The-Auto-Pentest
Give Chmod 777 Access Level
chmod 777 wafninja joomscan install-perl-module.sh yuki.sh
chmod 777 Module/WhatWeb/whatweb
And Then Install Python Module
pip install -r requirements.txt
After That Install Perl Module
./install-perl-module.sh
preparation finished now run this tool and happy pentest
Run This Tool
./yuki.sh

Screenshoots

 screenshot
screenshot screenshot screenshot screenshot 
Powered by Blogger.